Title : vCenter6.5 pre-upgrade checks issue

Title : vCenter6.5 pre-upgrade checks issue

While upgrading vCenter server from 5.5 to 6.5 this error occurred during pre-upgrade checks.

Error message: Please ensure extensions are compatible with the new vCenter server and re-register extensions with the new vCenter server after upgrade. Please refer to the vSphere documentation on extensions and the upgrade and interoperability guides. The user associated with the DSN has insufficient privileges. Resolution: provide sufficient privileges for the user by granting the user the following permissions: View server state and View any definition

Resolution

To resolve the issue, grant additional privileges to the vCenter Server database user.

  1. From the server that is hosting the vCenter Server database, open the Microsoft SQL Management Studio.
  2. Click New Query.

Run this query to grant the appropriate permissions to the user that the vCenter Server uses to connect to the database:

  1. use master
    go
    grant VIEW SERVER STATE to [VC database name]
    go
    GRANT VIEW ANY DEFINITION TO [VC database name]
    go